CCNA Explorer 2 Static Routing

From House of Technology
Jump to: navigation, search

Static Routing

Routers and Network

Examining the Connections of the Router

Connectors
DB60 Connector
Smart Serial Connector
UTP

Examining Router Interfaces

Vis kommandoerne i packet tracer
  • show ip route
  • show interfaces
  • show ip interfaces brief
  • show running-config

Configure an Ethernet Interface

R1(config)#interface fastethernet 0/0
R1(config-if)#ip address 172.16.3.1 255.255.255.0
R1(config-if)#no shutdown
Command interrupted by unsolicited message from IOS
logging synchronous

Verify Ethernet interfaces

show interfaces fastethernet 0/0
show ip interface brief

Router#show running-config
<output omitted>
interface FastEthernet0/0
ip address 172.16.3.1 255.255.255.0
<output omitted>
Router(config-if)#int fa0/1
Router(config-if)#ip address 172.16.3.2 255.255.255.0
172.16.3.0 overlaps with FastEthernet0/0
Router(config-if)#

Configure A Serial Interface

Router(config)#interface serial 0/0/0
Router(config-if)#ip address 172.16.2.1 255.255.255.0
Router(config-if)#no shutdown

Examining Router Interfaces

Telco Connection
Telco Connection

Exploring Directly Connected Networks

Verify Changes to the Routing Table

Router(config)#interface fastethernet 0/0
Router(config-if)#no shut

%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

RT: interface FastEthernet0/0 added to routing table
RT: add 10.0.0.0/24 via 0.0.0.0, connected metric [0/0]
Router(config-if)#end
Router#undebug all

Devices on Directly Connected Networks

Route table lookup
Route table lookup

Cisco Discovery Protocol (CDP)

Find lag 2 naboer med CDP

CDP

CDP privides the following information:

  • Device identifiers - For example, the configured host name of a switch
  • Address list - Up to one Network layer address for each protocol supported
  • Port identifier - The name of the local and remote port-in the form of an ASCII character string such as ethernet0
  • Capabilities list - For example, whether this device is a router or a switch
  • Platform - The hardware platform of the device; for example, a Cisco 7200 series router

CDP Timers[1]:
Hello Timer: 60 Sec
Hold Timer: 180 Sec
Vis cdp naboer i packet tracer...

Using CDP for Network Discovery

CDP er en sikkerhedsrisiko da den giver information omkring ens udstyr. Det bør derfor slåes fra på porte ud mod brugerne.

Disable globaly:

Router(config)#no cdp run

Disable per interface:

Router(config-if)#no cdp enable

Static Routes with "Next Hop" Addresses

Purpose and Command Syntax of ip route

Stub network
ip route Command

Configure Static Routes

Static Routes

Routing Table Principles and Static Routes

Alex Zinin's Routing Principles:

Principle 1: "Every router makes its decision alone, based on the information it has in its own routing table."
Principle 2: "The fact that one router has certain information in its routing table does not mean that other routers have the same information."
Principle 3: "Routing information about a path from one network to another does not provide routing information about the reverse, or return path."

Resolving to an Exit Interface

Nå en router skal slå op 2 gange i routing tabellen kaldes det "Recursive lookup"

Recursive Lookup

Hvis den ikke kan lave en recursive lookup, fjernes den oprindelige route fra tabellen.

Static Routes with Exit Interfaces

Configuring a Static Route with an Exit Interface

ip route Command

Bruges på point-to-point links.
Laver kun 1 opslag i routning tabellen.

Modifying Static Routes

Router(config)#ip route 192.168.2.0 255.255.255.0 172.16.2.2

Router(config)#no ip route 192.168.2.0 255.255.255.0 172.16.2.2

Router(config)#ip route 192.168.2.0 255.255.255.0 serial 0/0/0

Static Routes with Ethernet Interfaces

På et multiaccess netværk kender vi ikke lag2 next hop. Hvordan kan man så undgå recursive lookups?

Router(config)#ip route 192.168.2.0 255.255.255.0 fastethernet 0/1 172.16.2.2

Ved at angive next hop interface og IP kan vi undgå recursive lookups. Der skal dog stadig en ARP til at finde MAC addressen på modtageren

Summary and Default Static Routes

Summary Static Routes

Summary Routes
Router(config)#ip route 172.16.0.0 255.255.252.0 Serial0/0/1

Default Static Route

Default Static Routes
Router(config)#ip route 0.0.0.0 0.0.0.0 [exit-interface | ip-address ]
Show ip route

Chapter Summary

Summary