Aggregated Ethernet JUNOS
Contents
Aggregated Ethernet
Svarer til etherchannels på cisco kasser. Altså en bundling af flere links for at øge hastigheden.
Juniper bruger IEEE 802.1ad protocollen og understøtter også overvågning med LACP.[1]
Der kan maks være 10 interfaces i en aggregated bundle[2]
Læs mere on Juniper load balancing her.
Juniper konfiguration
I dette setup er en Juniper SRX100 forbundet til en Cisco 2960G Switch, fra fe-0/0/1 til Gi0/1 og fe-0/0/2 til Gi0/2
Konfigurere bundling devices
For at konfigurere aggregated porte på juniper skal der reserveres resourcer til det via chassis aggregated-devices. Her er der konfigureret en bundle:
root@SRX100> <input>show configuration chassis</input>
aggregated-devices {
ethernet {
device-count <notice>1</notice>;
}
}
Bundle interfacet
der skal oprettes et aggregated ethernet interfaces som konfigureres som et almindelig standalone interface. Her interfacet konfigureret med trunk og LACP:
root@SRX100> <input>show configuration interfaces ae0</input>
<notice>aggregated-ether-options {
lacp {
active;
}
}</notice>
unit 0 {
family ethernet-switching {
port-mode trunk;
vlan {
members all;
}
native-vlan-id 1;
}
}
Fysiske interfaces
De fysiske interfaces skal kædes sammen med bundle interfacet.
rooth@SRX100> <input>show configuration interfaces fe-0/0/1</input>
fastether-options {
<notice>802.3ad ae0;</notice>
}
root@SRX100> <input>show configuration interfaces fe-0/0/2</input>
fastether-options {
<notice>802.3ad ae0;</notice>
}
Verificering
root@SRX100> <input>show interfaces ae0</input>
Physical interface: ae0, Enabled, Physical link is Up
Interface index: 147, SNMP ifIndex: 546
Link-level type: Ethernet, MTU: 1514, <notice>Speed: 200mbps</notice>, BPDU Error: None, MAC-REWRITE Error: None, Loopback: Disabled, Source filtering: Disabled, Flow control: Disabled,
Minimum links needed: 1, Minimum bandwidth needed: 0
Device flags : Present Running
Interface flags: SNMP-Traps Internal: 0x0
Current address: 28:c0:da:dd:75:40, Hardware address: 28:c0:da:dd:75:40
Last flapped : 2014-09-30 10:25:53 CEST (00:14:44 ago)
Input rate : 11104 bps (9 pps)
Output rate : 9232 bps (13 pps)
Logical interface ae0.0 (Index 91) (SNMP ifIndex 547)
Flags: SNMP-Traps 0x0 Encapsulation: ENET2
Statistics Packets pps Bytes bps
Bundle:
Input : 5583 6 1358657 4096
Output: 6403 13 1156563 17320
Security: Zone: Null
Protocol eth-switch, MTU: 0
Flags: Trunk-Mode
root@SRX100> <input>show interfaces terse | match "fe-|ae0"</input>
fe-0/0/1 up up
fe-0/0/1.0 up up <notice>aenet --> ae0.0</notice>
fe-0/0/2 up up
fe-0/0/2.0 up up <notice>aenet --> ae0.0</notice>
ae0 up up
ae0.0 up up eth-switch
traceoptions for lacp finde også[3].
Cisco Switch konfiguration
Konfigurationen af EtherChannel på Cisco IOS kaldes for etherchannels eller port-channels
switch#<input>show run | be 0/1</input>
interface GigabitEthernet0/1
description >SRX100 Po2<
switchport mode trunk
<notice>channel-protocol lacp</notice>
channel-group 2 mode active
!
interface GigabitEthernet0/2
description >SRX100 Po2<
switchport mode trunk
<notice>channel-protocol lacp</notice>
channel-group 2 mode active
!
interface Port-channel2
description >SRX100 Trunk<
<notice>switchport mode trunk</notice>
!
Verificering
switch#<input>show int status</input>
Port Name Status Vlan Duplex Speed Type
Gi0/1 >SRX100 Po2< connected trunk a-full a-100 10/100/1000BaseTX
Gi0/2 >SRX100 Po2< connected trunk a-full a-100 10/100/1000BaseTX
...
Po2 >SRX100 Trunk< <notice>connected trunk a-full a-100</notice>
switch#<input>show etherchannel summary</input>
Flags: D - down P - bundled in port-channel
I - stand-alone s - suspended
H - Hot-standby (LACP only)
R - Layer3 S - Layer2
U - in use f - failed to allocate aggregator
M - not in use, minimum links not met
u - unsuitable for bundling
w - waiting to be aggregated
d - default port
Number of channel-groups in use: 2
Number of aggregators: 2
Group Port-channel Protocol Ports
------+-------------+-----------+-----------------------------------------------
<notice>2 Po2(SU) LACP Gi0/1(P) Gi0/2(P)</notice>