BGP Cisco IOS IPv6

From Teknologisk videncenter
Jump to: navigation, search

IPv6 eBGP

interface fastethernet0/0
 ipv6 address 2001:410:ffff:1::1/64
 ipv6 nd suppress-ra
!
ipv6 route ::/0 fastethernet0/0 fe80::250:3eff:fea4:5f12
!
router bgp 100
 no bgp default ipv4-unicast
 bgp router-id 1.1.1.1
 neighbor 3ffe:b00:ffff:2::2 remote-as 200
 address-family ipv6
  neighbor 3ffe:b00:ffff:2::2 activate
 exit-address-family

Advertising IPv4 through IPv6 and IPv6 through IPv4

You will have to understand the MBGP address families. One of the basic rule of MBGP is that when I'm advertising a route from a specific address family, the next hop has to be from the same address family. So, you will have to make sure the next hop is from the same address family. Couple of examples for you: A basic rule of mBGP is that when advertising a route from a specific Address-family the next-hop address has to be from the same address-family, or you will have to use roue-maps.

IPv6 route through BGP IPv4 neighbor

To pass the NLRI - Next-Hop address -

1. IPv6 NLRI in IPv4

router bgp 300 
 bgp router-id 192.168.146.1
 neighbor 192.168.151.1 remote-as 400
!
address-family ipv6
neighbor 192.168.151.1 activate
neighbor 192.168.151.1 route-map IPv6NEXTHOP out
network 2001:16d8:dd85::/48
!
route-map IPv6NEXTHOP permit 10
set ipv6 next-hop 2150:1:1::3

IPv4 route through BGP IPv6 neighbor

router bgp 300
bgp router-id 192.168.30.1
neighbor 2150:1:1::2 remote-as 400
!
address-family ipv4
neighbor 2150:1:1::2 activate
neighbor 2150:1:1::2 route-map IPv4NEXTHOP out
network 192.10.0.0
!
route-map IPv4NEXTHOP permit 10
set ip next-hop 150.1.1.3


Links