GRE JUNOS
From Teknologisk videncenter
GRE Tunnel på juniper
For at lave en IPv4+IPv6 GRE[1] tunnel imellem en Cisco IOS og en Juniper SRX skal der noget configuration til.
Junos
selve tunellen
[edit interfaces gr-0/0/0]
root@Router# show
unit 0 {
description mercantec.elmholt.eu;
tunnel {
source yderside.domain1.com;
destination yderside.domain2.com;
}
family inet {
address 10.255.0.13/30;
}
family inet6 {
address fec0::/64 {
eui-64;
}
}
}
Og lidt configuration til en statick route
[edit routing-options]
root@Router# show
rib inet6.0 {
static {
route 2001:16d8:cafe::/48 next-hop fec0::cafe:cfff:fe96:f76e;
}
}
Og hvis vi skal pinge skal der GRE interfacet være i trust zonen. Det er jo en SRX[2]
[edit security zones security-zone trust]
root@Router# show
interfaces {
gr-0/0/0.0;
}
På Cisco kassen
GRE interfaces
interface Tunnel0
ip address 10.255.0.14 255.255.255.252
ipv6 address FEC0::/64 eui-64
tunnel source FastEthernet0/0
tunnel destination yderside.domain1.com
end
og den staticke route
ipv6 route 2001:16D8:caff::/48 FEC0::cafe:cafe:DD:7500