IP TECH III/MPLS

From Teknologisk videncenter
Jump to: navigation, search

Setup

MPLS8.png

Eksempel på PE Router

Konfiguration

hostname R7
!
enable secret 5 $1$QRf3$uU49i1qFDdhIP2bG5KMDd.
enable password class
!
ip cef
!
ip vrf kunde-a
 rd 200:200
 route-target export 200:1000
 route-target import 200:1000
!
ip vrf kunde-b
 rd 200:150
 route-target export 200:2000
 route-target import 200:2000
!
interface Loopback0
 description Used as Router-ID
 ip address 7.7.7.7 255.255.255.255
!
interface Loopback10
 description Kunde-A interface
 ip vrf forwarding kunde-a
 ip address 192.168.4.1 255.255.255.0
!
interface Loopback11
 description Kunde-B interface
 ip vrf forwarding kunde-b
 ip address 192.168.4.1 255.255.255.0
!
interface FastEthernet0/0
 description Forbundet til P router
 ip address 172.16.7.1 255.255.255.252
 ip router isis
 mpls ip
!
router isis
 net 49.0001.0070.0700.7007.00
 passive-interface Loopback0
!
router bgp 200
 bgp log-neighbor-changes
 neighbor 1.1.1.1 remote-as 200
 neighbor 1.1.1.1 update-source Loopback0
 neighbor 4.4.4.4 remote-as 200
 neighbor 4.4.4.4 update-source Loopback0
 neighbor 6.6.6.6 remote-as 200
 neighbor 6.6.6.6 update-source Loopback0
 !
 address-family ipv4
 neighbor 1.1.1.1 activate
 neighbor 4.4.4.4 activate
 neighbor 6.6.6.6 activate
 no auto-summary
 no synchronization
 network 7.7.7.7 mask 255.255.255.255
 exit-address-family
 !
 address-family vpnv4
 neighbor 1.1.1.1 activate
 neighbor 1.1.1.1 send-community both
 neighbor 4.4.4.4 activate
 neighbor 4.4.4.4 send-community both
 neighbor 6.6.6.6 activate
 neighbor 6.6.6.6 send-community both
 exit-address-family
 !
 address-family ipv4 vrf kunde-b
 redistribute connected
 no synchronization
 exit-address-family
 !
 address-family ipv4 vrf kunde-a
 redistribute connected
 no synchronization
 exit-address-family
!
mpls ldp router-id Loopback0 force
!

line con 0
line aux 0
line vty 0 4
 exec-timeout 0 0
 password cisco
 login
!

VRF route tabel

R7#<input>show ip route vrf kunde-a</input>

Routing Table: kunde-a
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

C    192.168.4.0/24 is directly connected, Loopback10
B    192.168.2.0/24 [200/0] via 4.4.4.4, 17:06:25
     192.168.3.0/32 is subnetted, 1 subnets
B       192.168.3.1 [200/0] via 6.6.6.6, 17:05:55

MPLS labels

R7#<input>show mpls forwarding-table</input>
Local  Outgoing    Prefix            Bytes tag  Outgoing   Next Hop
tag    tag or VC   or Tunnel Id      switched   interface
16     16          2.2.2.2/32        0          Fa0/0      172.16.7.2
17     17          3.3.3.3/32        0          Fa0/0      172.16.7.2
18     18          4.4.4.4/32        0          Fa0/0      172.16.7.2
19     19          5.5.5.5/32        0          Fa0/0      172.16.7.2
20     20          6.6.6.6/32        0          Fa0/0      172.16.7.2
21     Pop tag     172.16.8.0/30     0          Fa0/0      172.16.7.2
22     21          172.16.4.0/30     0          Fa0/0      172.16.7.2
23     Untagged    172.16.4.0/24     0          Fa0/1      192.168.146.1
24     Pop tag     172.16.5.0/30     0          Fa0/0      172.16.7.2
25     22          172.16.6.0/30     0          Fa0/0      172.16.7.2
26     23          172.16.2.4/30     0          Fa0/0      172.16.7.2
27     24          172.16.1.0/30     0          Fa0/0      172.16.7.2
28     25          172.16.2.0/30     0          Fa0/0      172.16.7.2
29     Untagged    172.16.4.66/32    0          Fa0/1      192.168.146.1
30     Pop tag     8.8.8.8/32        0          Fa0/0      172.16.7.2
31     26          1.1.1.1/32        0          Fa0/0      172.16.7.2
32     Aggregate   192.168.4.0/24[V] 0
33     Aggregate   192.168.4.0/24[V] 0

Eksempel på P router

!
hostname RR8
!
enable secret 5 $1$hXG5$ioYcYvc9P//dgR4CKFLS./
enable password class
!
ip cef
!
interface Loopback0
 ip address 8.8.8.8 255.255.255.255
!
interface FastEthernet0/0
 ip address 172.16.7.2 255.255.255.252
 ip router isis
 mpls ip
!
interface FastEthernet0/1
 ip address 172.16.5.2 255.255.255.252
 ip router isis
 mpls ip
!
interface Serial0/3/0
 ip address 172.16.8.1 255.255.255.252
 ip router isis
 mpls ip
!
router isis
 net 49.0001.0080.0800.8008.00
 is-type level-2-only
 passive-interface Loopback0
!
line con 0
line aux 0
line vty 0 4
 password cisco
 no login