IS-IS IPv6 Cisco IOS
From Teknologisk videncenter
(Redirected from IS-IS IPv6)
For generel IS-IS and IS-IS for Ipv4 see IS-IS
Contents
Configuring IPv6 IS-IS
IPv4/IPv6 Dualstack example
interface FastEthernet0/1
ip address 10.14.0.2 255.255.255.0
ip router isis
ipv6 address 2001:10:14::2/64
ipv6 router isis
isis circuit-type level-2-only
!
router isis
net 49.0000.0100.1125.5255.00
metric-style wide
passive-interface FastEthernet2/0
Enabling IPv6 on IPv4 networks
When enabling IPv6 IS-IS between two neighbors running IPv4 the adjacency is broken if not both Routers have IPv4 and IPv6 enabled simultaneously.
To avoid this situation it's necessary - at least temporarily - to disable adjacency check on IS-IS on all routers before IPv6 enabling.
Example
router isis
net 49.0000.0100.1125.5255.00
is-type level-2-only
metric-style wide
passive-interface FastEthernet2/0
!
address-family ipv6
<notice>no adjacency-check</notice>
exit-address-family
!
IPv6 IS-IS through IPv4 only islands
Because IS-IS uses CLNP and not IPv6 a standard IPv6-over-IPv4-Tunnel can't be used. A GRE tunnel through IPv4 is necessary.
Building the tunnel
R1
hostname R1
!
interface Tunnel10
description GRE tunnel over IPv4-only network to R2
ip address 192.168.218.1 255.255.255.0
ip router isis
ipv6 address 2001:16D8:DD85:A600::1/64
ipv6 enable
ipv6 router isis
isis circuit-type level-2-only
tunnel source FastEthernet0/1
tunnel destination 91.16.45.44
!
interface Loopback0
ip address 192.168.217.1 255.255.255.255
ip router isis
ipv6 address 2001:16D8:DD85:A501::1/128
ipv6 router isis
isis circuit-type level-2-only
!
interface FastEthernet0/1
description Connection to IPv4 only network
ip address 83.90.56.5 255.255.255.252
!
router isis
net 49.0000.1921.6821.7002.00
is-type level-2-only
metric-style wide
!
router bgp 3642
bgp router-id 192.168.217.1
no bgp default ipv4-unicast
neighbor PG-IPv6 peer-group
neighbor PG-IPv6 remote-as 3642
neighbor PG-IPv6 update-source Loopback0
neighbor PG-IPv4 peer-group
neighbor PG-IPv4 remote-as 3642
neighbor PG-IPv4 update-source Loopback0
neighbor 2001:16D8:DD85:A600::2 peer-group PG-IPv6
neighbor 192.168.225.1 peer-group PG-IPv4
!
address-family ipv4
neighbor 192.168.225.1 activate
no auto-summary
no synchronization
exit-address-family
!
address-family ipv6
neighbor 2001:16D8:DD85:A600::2 activate
exit-address-family
R2
hostname R2
!
interface Tunnel10
description GRE tunnel over IPv4-only network to R1
ip address 192.168.226.1 255.255.255.0
ip router isis
ipv6 address 2001:16D8:DD85:A600::2/64
ipv6 enable
ipv6 router isis
isis circuit-type level-2-only
tunnel source FastEthernet0/1
tunnel destination 83.90.56.5
!
interface Loopback0
ip address 192.168.225.1 255.255.255.255
ip router isis
ipv6 address 2001:16D8:DD85:A701::1/128
ipv6 router isis
isis circuit-type level-2-only
!
interface FastEthernet0/1
description Connection to IPv4 only network
ip address 91.16.45.44 255.255.255.252
!
router isis
net 49.0000.1921.6822.5001.00
is-type level-2-only
metric-style wide
!
router bgp 3642
bgp router-id 192.168.225.1
no bgp default ipv4-unicast
neighbor PG-IPv6 peer-group
neighbor PG-IPv6 remote-as 3642
neighbor PG-IPv6 update-source Loopback0
neighbor PG-IPv4 peer-group
neighbor PG-IPv4 remote-as 3642
neighbor PG-IPv4 update-source Loopback0
neighbor 2001:16D8:DD85:A501::1 peer-group PG-IPv6
neighbor 192.168.217.1 peer-group PG-IPv4
!
address-family ipv4
neighbor PEER next-hop-self
neighbor 192.168.217.1 activate
no auto-summary
no synchronization
exit-address-family
!
address-family ipv6
neighbor 2001:16D8:DD85:A501::1 activate
exit-address-family
Testing
CLNS throgh tunnel
R2#<input>show clns neighbors</input>
System Id Interface SNPA State Holdtime Type Protocol
R1 <notice>Tu10</notice> 83.90.56.5 Up 28 <notice>L2</notice> IS-IS
Testing
R2#<input>traceroute clns 49.0000.1921.6821.7002.00</input>
Type escape sequence to abort.
Tracing the route to 49.0000.1921.6821.7002.00
1 49.0000.1921.6821.7002.00 0 msec ! 0 msec ! 0 msec !