ITT 2013/Network module 1/Assignment Day 12/confHelpDNAT

From Teknologisk videncenter
Jump to: navigation, search
Setup

MyR1

MyR1#show run
Building configuration...
Current configuration : 765 bytes
!
version 12.4
!
hostname MyR1
!
interface FastEthernet0/0
 ip address 193.80.112.33 255.255.255.240
 ip nat outside
 no shutdown
!
interface FastEthernet0/1
 ip address 10.0.0.1 255.255.0.0
 ip nat inside
 no shutdown
!
<notice>ip nat pool My-Pool 193.80.112.40 193.80.112.45 netmask 255.255.255.240
ip nat inside source list 100 pool My-Pool</notice>
!
ip route 0.0.0.0 0.0.0.0 193.80.112.34 
!
access-list 100 permit ip 10.0.0.0 0.0.255.255 any
!
end

ISP

ISP#show run
Building configuration...
Current configuration : 515 bytes
!
version 12.4
!
hostname ISP
!
interface FastEthernet0/0
 ip address 80.112.0.1 255.255.255.0
 no shutdown
!
interface FastEthernet0/1
 ip address 193.80.112.34 255.255.255.240
 no shutdown
!
end

Connectivity test

The inside computer should be able to ping the outside host(PC3)

Ping

And the ICMP packet should be visible in the translationa table:

MyR1#<input>show ip nat statistics</input> 
Total translations: 0 (0 static, 0 dynamic, 0 extended)
Outside Interfaces: FastEthernet0/0
Inside Interfaces: FastEthernet0/1
Hits: 30  Misses: 37
Expired translations: 8
Dynamic mappings:
-- Inside Source
access-list 100 pool My-Pool refCount 0
 pool My-Pool: netmask 255.255.255.240
       start 193.80.112.40 end 193.80.112.45
       type generic, total addresses 6 , allocated 0 (0%), misses 0
MyR1#<input>show ip nat translations</input>
Pro  Inside global     Inside local       Outside local      Outside global
<notice>icmp 193.80.112.40:11  10.0.0.12:11       80.112.0.10:11     80.112.0.10:11
icmp 193.80.112.40:12  10.0.0.12:12       80.112.0.10:12     80.112.0.10:12
icmp 193.80.112.40:13  10.0.0.12:13       80.112.0.10:13     80.112.0.10:13
icmp 193.80.112.40:14  10.0.0.12:14       80.112.0.10:14     80.112.0.10:14
icmp 193.80.112.40:15  10.0.0.12:15       80.112.0.10:15     80.112.0.10:15
icmp 193.80.112.40:16  10.0.0.12:16       80.112.0.10:16     80.112.0.10:16
icmp 193.80.112.40:17  10.0.0.12:17       80.112.0.10:17     80.112.0.10:17
icmp 193.80.112.40:18  10.0.0.12:18       80.112.0.10:18     80.112.0.10:18</notice>

MyR1#