ITT 2013/Network module 1/Assignment Day 12/confHelpSNAT

From Teknologisk videncenter
Jump to: navigation, search
Setup

MyR1

MyR1#show run
Building configuration...
Current configuration : 765 bytes
!
version 12.4
!
hostname MyR1
!
interface FastEthernet0/0
 ip address 193.80.112.33 255.255.255.240
 ip nat outside
 no shutdown
!
interface FastEthernet0/1
 ip address 10.0.0.1 255.255.0.0
 ip nat inside
 no shutdown
!
<notice>ip nat pool My-Pool 193.80.112.40 193.80.112.45 netmask 255.255.255.240
ip nat in sou static 10.0.100.100 193.80.112.35
ip nat inside source list 100 pool My-Pool</notice>
!
ip route 0.0.0.0 0.0.0.0 193.80.112.34 
!
access-list 100 permit ip 10.0.0.0 0.0.255.255 any
!
end

ISP

ISP#show run
Building configuration...
Current configuration : 515 bytes
!
version 12.4
!
hostname ISP
!
interface FastEthernet0/0
 ip address 80.112.0.1 255.255.255.0
 no shutdown
!
interface FastEthernet0/1
 ip address 193.80.112.34 255.255.255.240
 no shutdown
!
end

Connectivity test

The inside computer should be able to ping the outside host(PC3)

Ping

And the internet host should be able to connect to the server on the public address:

Web Server

And the ICMP packet should be visible in the translationa table:

MyR1#<input>show ip nat statistics</input> 
Total translations: 4 (1 static, 3 dynamic, 3 extended)
Outside Interfaces: FastEthernet0/0
Inside Interfaces: FastEthernet0/1
Hits: <notice>46</notice>  Misses: 48
Expired translations: 16
Dynamic mappings:
-- Inside Source
access-list 100 pool My-Pool refCount 2
 pool My-Pool: netmask 255.255.255.240
       start 193.80.112.40 end 193.80.112.45
       type generic, total addresses 6 , allocated 1 (16%), misses 0
MyR1#<input>show ip nat translations</input>
Pro  Inside global     Inside local       Outside local      Outside global
<notice>icmp 193.80.112.40:19  10.0.0.12:19       80.112.0.10:19     80.112.0.10:19
icmp 193.80.112.40:20  10.0.0.12:20       80.112.0.10:20     80.112.0.10:20</notice>
---  193.80.112.35     10.0.100.100       ---                ---
<notice>tcp 193.80.112.35:80   10.0.100.100:80    80.112.0.10:1029   80.112.0.10:1029</notice>

MyR1#