ITT 2014/Network module 1/Assignment Day 13
From Teknologisk videncenter
< ITT 2014 | Network module 1
Contents
Setup
IPv4
The task is now to configure IPv4 in the setup. And make sure all the devices can ping each other.
IPv4 Connectivity
- Configure all the IPv4 addresses in the setup.
- The lowest IP address should be configured on the router with the lowest router number, on the interface.
- Make sure you can ping all the neighbour interfaces
Commands
R1#<input>show run</input>
interface FastEthernet0/0
ip address 10.0.0.1 255.255.255.0
no shutdown
!
interface Serial0/0/0
ip address 192.168.0.1 255.255.255.252
no shutdown
!
interface Serial0/0/1
ip address 192.168.0.9 255.255.255.252
no shutdown
R1#<input>ping 192.168.0.2</input>
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.0.2, timeout is 2 seconds:
!!!!!
<notice>Success rate is 100 percent (5/5)</notice>, round-trip min/avg/max = 1/8/13 ms
R1#
R1#<input>show ip int brief</input>
Interface IP-Address OK? Method Status Protocol
<notice>FastEthernet0/0 10.0.0.1 YES manual up up</notice>
FastEthernet0/1 unassigned YES unset administratively down down
<notice>Serial0/0/0 192.168.0.1 YES manual up up
Serial0/0/1 192.168.0.9 YES manual up up</notice>
Serial0/1/0 unassigned YES unset administratively down down
Serial0/1/1 unassigned YES unset administratively down down
Vlan1 unassigned YES unset administratively down down
IPv4 RIP
- Configure RIPv2 on all the devices
- Disable auto-summarization on RIP
R1#<input>show run</input>
< output omitted >
router rip
version 2
! Enable routing on all network within the 10.0.0.0/8 range
network 10.0.0.0
! Enable routing on all network within the 192.168.0.0/24 range
network 192.168.0.0
no auto-summary
R1#<input>show ip route</input>
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route
Gateway of last resort is not set
10.0.0.0/24 is subnetted, 4 subnets
C 10.0.0.0 is directly connected, FastEthernet0/0
<notice>R 10.0.1.0 [120/1] via 192.168.0.2, 00:00:08, Serial0/0/0
R 10.0.2.0 [120/2] via 192.168.0.10, 00:00:03, Serial0/0/1
R 10.0.3.0 [120/1] via 192.168.0.10, 00:00:03, Serial0/0/1</notice>
192.168.0.0/30 is subnetted, 4 subnets
C 192.168.0.0 is directly connected, Serial0/0/0
<notice>R 192.168.0.4 [120/1] via 192.168.0.2, 00:00:08, Serial0/0/0
[120/1] via 192.168.0.10, 00:00:03, Serial0/0/1</notice>
C 192.168.0.8 is directly connected, Serial0/0/1
<notice>R 192.168.0.12 [120/1] via 192.168.0.10, 00:00:03, Serial0/0/1</notice>
IPv6
We now need to configure IPv6 addresses and routing in the setup to create a Dual-Stack network.
IPv6 Connectivity
- Configure IPv6 addresses on all the interfaces
- Make sure you can ping the neighbour interfaces
R1#<input>show run</input>
interface FastEthernet0/0
ipv6 address 2001:DB8:CAFE::1/64
!
interface Serial0/0/0
ipv6 address 2001:DB8:CAFE:100A::1/64
!
interface Serial0/0/1
ipv6 address 2001:DB8:CAFE:100B::1/64
R1#<input>show ipv6 interface brief</input>
<notice>FastEthernet0/0 [up/up]</notice>
FE80::20D:BDFF:FE84:8301
<notice>2001:DB8:CAFE::1</notice>
FastEthernet0/1 [administratively down/down]
<notice>Serial0/0/0 [up/up]</notice>
FE80::202:16FF:FE90:8101
<notice>2001:DB8:CAFE:100A::1</notice>
<notice>Serial0/0/1 [up/up]</notice>
FE80::202:16FF:FE90:8102
<notice>2001:DB8:CAFE:100C::1</notice>
Serial0/1/0 [administratively down/down]
Serial0/1/1 [administratively down/down]
Vlan1 [administratively down/down]
R1#<input>ping 2001:DB8:CAFE:100A::2</input>
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2001:DB8:CAFE:100A::2, timeout is 2 seconds:
<notice>!!!!!</notice>
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/3/9 ms
R1#
IPv6 RIP
- Configure RIPng on all the interfaces
R1#<input>show run</input>
interface FastEthernet0/0
ipv6 rip <notice>RIP-V6</notice> enable
!
interface Serial0/0/0
ipv6 rip <notice>RIP-V6</notice> enable
!
interface Serial0/0/1
ipv6 rip <notice>RIP-V6</notice> enable
R1#<input>show ipv6 route</input>
IPv6 Routing Table - 12 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
U - Per-user Static route, M - MIPv6
I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
D - EIGRP, EX - EIGRP external
C 2001:DB8:CAFE::/64 [0/0]
via ::, FastEthernet0/0
L 2001:DB8:CAFE::1/128 [0/0]
via ::, FastEthernet0/0
<notice>R 2001:DB8:CAFE:1::/64 [120/2]
via FE80::260:5CFF:FEE4:DB6D, Serial0/0/0
R 2001:DB8:CAFE:2::/64 [120/3]
via FE80::260:2FFF:FEE5:C081, Serial0/0/1
R 2001:DB8:CAFE:3::/64 [120/2]
via FE80::260:2FFF:FEE5:C081, Serial0/0/1</notice>
C 2001:DB8:CAFE:100A::/64 [0/0]
via ::, Serial0/0/0
L 2001:DB8:CAFE:100A::1/128 [0/0]
via ::, Serial0/0/0
C 2001:DB8:CAFE:100B::/64 [0/0]
via ::, Serial0/0/1
L 2001:DB8:CAFE:100B::1/128 [0/0]
via ::, Serial0/0/1
<notice>R 2001:DB8:CAFE:100C::/64 [120/2]
via FE80::260:2FFF:FEE5:C081, Serial0/0/1
R 2001:DB8:CAFE:100D::/64 [120/2]
via FE80::260:2FFF:FEE5:C081, Serial0/0/1</notice>
L FF00::/8 [0/0]
via ::, Null0
R1#