MPLS
From Teknologisk videncenter
Contents
Multiprotocol Protocol Label Switching
Eksempel på MPLS LER router. (Label Edge Router)
<input>ip cef</input>
!
<input>ip vrf PB
description Kunde: Pengebanken (PB) i Birksund (BKS) : PB-BKS
rd 1100:1
route-target export 1100:1
route-target import 1100:1</input>
!
<input>ip vrf SF
description Kunde: Steel Furniture i Birksund
rd 1000:1
route-target export 1000:1
route-target import 1000:1</input>
!
interface Loopback0
ip address 10.10.10.1 255.255.255.255
ip router isis
!
interface FastEthernet0/0
description Forbindelse til 3550RDB1
bandwidth 10000
ip address 192.168.11.1 255.255.255.0
ip router isis
speed 10
full-duplex
<input>mpls label protocol ldp
tag-switching ip</input> ! or mpls ip
!
interface FastEthernet0/0.100
description VLAN for Steel Furniture (SF) i Rodborg (RDB)
bandwidth 2000
encapsulation dot1Q 100
<input>ip vrf forwarding SF</input>
ip address 172.24.0.1 255.255.0.0
no ip redirects
no ip proxy-arp
no snmp trap link-status
!
interface FastEthernet0/0.200
description VLAN for Pengebanken (PB) i Rodborg (RDB) : PB-RDB
bandwidth 2000
encapsulation dot1Q 200
<input>ip vrf forwarding PB</input>
ip address 172.28.0.1 255.255.0.0
no ip redirects
no ip proxy-arp
no snmp trap link-status
!
interface Serial0/0
mtu 1508
bandwidth 4000
ip address 192.168.90.1 255.255.255.252
ip router isis
<input>mpls label protocol ldp
tag-switching ip</input>
!
router isis
net 49.0000.0101.3300.1111.00
is-type level-2-only
metric-style wide
!
router bgp 65000
bgp log-neighbor-changes
neighbor 10.10.10.3 remote-as 65000
neighbor 10.10.10.3 update-source Loopback0
!
address-family ipv4
neighbor 10.10.10.3 activate
no auto-summary
no synchronization
exit-address-family
!
<input>address-family vpnv4
neighbor 10.10.10.3 activate
neighbor 10.10.10.3 send-community extended
exit-address-family</input>
!
<input>address-family ipv4 vrf SF
redistribute connected
no auto-summary
no synchronization
exit-address-family</input>
!
<input>address-family ipv4 vrf PB
redistribute connected
no auto-summary
no synchronization
redistribute static
exit-address-family</input>
!
<input> ip route vrf PB 172.21.0.0 255.255.0.0 172.28.0.2</input>
Eksempel på LSR Router (Label Switch Router)
<input>ip cef</input>
!
interface Loopback0
ip address 10.10.10.2 255.255.255.255
ip router isis
!
interface Serial0/0
mtu 1508
bandwidth 8000
ip address 192.168.90.5 255.255.255.252
ip nat inside
ip router isis
<input>mpls label protocol ldp
tag-switching ip</input>
clock rate 8000000
!
interface Serial0/1
mtu 1508
bandwidth 8000
ip address 192.168.90.2 255.255.255.252
ip nat inside
ip router isis
<input>mpls label protocol ldp
tag-switching ip</input>
clock rate 8000000
!
router isis
net 49.0000.0101.3300.2222.00
is-type level-2-only
metric-style wide
default-information originate
!
Notater
Når to routere laver en LDP session mellem naboer bruges højeste Loopback adresse. Derfor skal naboen kende denne adresse. Brug
R3(config)#<input>mpls ldp router-id loopback 0</input>
Check at LDP til naboen er oppe
R3#<input>sh mpls ldp neighbor</input>
Peer LDP Ident: 10.1.2.1:0; Local LDP Ident 10.1.5.1:0
TCP connection: 10.1.2.1.646 - 10.1.5.1.51150
State: Oper; Msgs sent/rcvd: 1785/1777; Downstream
Up time: 1d01h
LDP discovery sources:
Serial0/0, Src IP addr: 10.1.1.10
Addresses bound to peer LDP Ident:
10.1.1.25 10.1.1.10 10.1.2.1
Learning materials
Cisco IOS MPLS konfiguration del 1
Cisco IOS MPLS konfiguration del 2