Netband Project - IPSec/Gre

From Teknologisk videncenter
Jump to: navigation, search

IPSec/Gre

This page is part of the Netband Project

Configuration for the Head-End

This configuration is for the "server" part of the tunnel, with the static IP.

crypto isakmp policy 10
 encr aes 256
 authentication pre-share
 group 5
 lifetime 1000
!
crypto isakmp key CiscoDisco address 0.0.0.0 0.0.0.0
!
crypto ipsec transform-set Netband-AES256-SHA esp-aes 256 esp-sha-hmac
!
crypto dynamic-map Netband-dynamic 10
 description Hmmm
 set transform-set Netband-AES256-SHA
!
crypto map Netband-crypto 10 ipsec-isakmp dynamic Netband-dynamic
!
interface Tunnel0
 ip address 10.255.254.1 255.255.255.252
 ip mtu 1420
 tunnel source Loopback1
 tunnel destination 10.255.253.2
!
interface Loopback1
 ip address 10.255.253.1 255.255.255.255
!
ip route 10.255.253.2 255.255.255.255 192.168.0.1

Configuration for the Branch

This configuration is for the "client" part of the tunnel, with the dynamic IP.

crypto isakmp policy 10
 encr aes 256
 authentication pre-share
 group 5
 lifetime 1000
!
crypto isakmp key CiscoDisco address 192.168.0.11
!
crypto ipsec transform-set Netband-AES256-SHA esp-aes 256 esp-sha-hmac
!
crypto map Netband-crypto 10 ipsec-isakmp
 set peer 192.168.0.11
 set transform-set Netband-AES256-SHA
 match address Tunnel_to_HQ
!
interface Tunnel0
 ip address 10.255.254.2 255.255.255.252
 ip mtu 1420
 tunnel source Loopback1
 tunnel destination 10.255.253.1
!
interface Loopback1
 ip address 10.255.253.2 255.255.255.255
!
ip access-list extended Tunnel_to_HQ
 permit gre host 10.255.253.2 host 10.255.253.1
!
ip route 10.255.253.1 255.255.255.255 FastEthernet0/0

External links

http://www.cisco.com/en/US/docs/ios/12_3/security/command/reference/sec_c2g.html#wp1073142
http://www.cisco.com/en/US/docs/solutions/Enterprise/WAN_and_MAN/P2P_GRE_IPSec/5_p2pGRE.html#wp84798