OSPF IPv6 Cisco IOS
From Teknologisk videncenter
Configurering IPv6 OSPF
The following setup os used in the examples:
interface FastEthernet0/0
ip address 10.0.0.1 255.255.255.0
ipv6 address 2001:DB8:CAFE::1/64
<notice>ipv6 ospf 1 area 1</notice>
!
interface Serial0/0/0
ip address 192.168.0.1 255.255.255.252
ipv6 address 2001:DB8:CAFE:100A::1/64
<notice>ipv6 ospf 1 area 0</notice>
!
interface Serial0/0/1
ip address 192.168.0.9 255.255.255.252
ipv6 address 2001:DB8:CAFE:100B::1/64
<notice>ipv6 ospf 1 area 0</notice>
!
ipv6 router ospf 1
router-id <notice>0.0.0.1</notice>
log-adjacency-changes
passive-interface FastEthernet0/0
Testing
OSPFv3 Neighbors
R1#<input>show ipv6 ospf neighbor</input>
Neighbor ID Pri State Dead Time Interface ID Interface
0.0.0.2 0 FULL/ - 00:00:38 3 Serial0/0/0
0.0.0.3 0 FULL/ - 00:00:34 4 Serial0/0/1
R1#
OSPFv3 Database
R1#<input>show ipv6 ospf database</input>
OSPF Router with ID (0.0.0.1) (Process ID 1)
Router Link States (Area 1)
ADV Router Age Seq# Fragment ID Link count Bits
0.0.0.1 566 0x80000002 0 0 B
Inter Area Prefix Link States (Area 1)
ADV Router Age Seq# Metric Prefix
0.0.0.1 582 0x80000001 64 2001:DB8:CAFE:100A::/64
0.0.0.1 572 0x80000002 64 2001:DB8:CAFE:100B::/64
0.0.0.1 489 0x80000003 65 2001:DB8:CAFE:1::/64
0.0.0.1 394 0x80000004 128 2001:DB8:CAFE:100C::/64
0.0.0.1 394 0x80000005 128 2001:DB8:CAFE:100D::/64
0.0.0.1 394 0x80000006 65 2001:DB8:CAFE:3::/64
0.0.0.1 325 0x80000007 129 2001:DB8:CAFE:2::/64
Link (Type-8) Link States (Area 1)
ADV Router Age Seq# Link ID Interface
0.0.0.1 605 0x80000001 1 Fa0/0
Intra Area Prefix Link States (Area 1)
ADV Router Age Seq# Link ID Ref-lstype Ref-LSID
0.0.0.1 605 0x80000001 2 0x2001 0
OSPF Router with ID (0.0.0.1) (Process ID 1)
Router Link States (Area 0)
ADV Router Age Seq# Fragment ID Link count Bits
0.0.0.2 413 0x80000003 0 2 B
0.0.0.1 400 0x80000004 0 2 B
0.0.0.3 339 0x80000004 0 3 B
0.0.0.4 339 0x80000002 0 1 B
Inter Area Prefix Link States (Area 0)
ADV Router Age Seq# Metric Prefix
0.0.0.1 582 0x80000001 1 2001:DB8:CAFE::/64
0.0.0.2 503 0x80000001 1 2001:DB8:CAFE:1::/64
0.0.0.3 416 0x80000001 1 2001:DB8:CAFE:3::/64
0.0.0.4 343 0x80000001 1 2001:DB8:CAFE:2::/64
Link (Type-8) Link States (Area 0)
ADV Router Age Seq# Link ID Interface
0.0.0.1 515 0x80000003 3 Se0/0/0
0.0.0.2 507 0x80000004 3 Se0/0/0
0.0.0.1 409 0x80000004 4 Se0/0/1
0.0.0.3 400 0x80000004 4 Se0/0/1
Intra Area Prefix Link States (Area 0)
ADV Router Age Seq# Link ID Ref-lstype Ref-LSID
0.0.0.1 579 0x80000002 2 0x2001 0
0.0.0.2 493 0x80000004 2 0x2001 0
0.0.0.3 399 0x80000003 2 0x2001 0
0.0.0.4 347 0x80000001 2 0x2001 0
R1#
IPv6 Routing table
R1#<input>show ipv6 route ospf</input>
IPv6 Routing Table - 12 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
U - Per-user Static route, M - MIPv6
I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
D - EIGRP, EX - EIGRP external
OI 2001:DB8:CAFE:1::/64 [110/65]
via FE80::260:5CFF:FEE4:DB6D, Serial0/0/0
OI 2001:DB8:CAFE:2::/64 [110/129]
via FE80::260:2FFF:FEE5:C081, Serial0/0/1
OI 2001:DB8:CAFE:3::/64 [110/65]
via FE80::260:2FFF:FEE5:C081, Serial0/0/1
O 2001:DB8:CAFE:100C::/64 [110/128]
via FE80::260:2FFF:FEE5:C081, Serial0/0/1
O 2001:DB8:CAFE:100D::/64 [110/128]
via FE80::260:2FFF:FEE5:C081, Serial0/0/1
R1#
show ipv6 protocols
R1#<input>show ipv6 protocols</input>
IPv6 Routing Protocol is "connected"
IPv6 Routing Protocol is "ospf 1"
Interfaces (Area 1)
<notice>FastEthernet0/0</notice>
Interfaces (Area 0)
<notice>Serial0/0/0
Serial0/0/1</notice>
R1#
Stub Areas
This output is from another example.
Stub ABR
This router havn't got any OSPF External Routes.
R1#<input>show run</input>
interface FastEthernet0/1
ipv6 enable
<notice>ipv6 ospf 1 area 0</notice>
!
interface FastEthernet1/0
ipv6 enable
<notice>ipv6 ospf 1 area 1</notice>
!
ipv6 router ospf 1
router-id 0.0.0.1
<notice>area 1 stub</notice>
!
R1#<input>show ipv route ospf</input>
IPv6 Routing Table - 7 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
U - Per-user Static route
I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
O 2001::2/128 [110/1]
via FE80::C801:9FF:FE90:6, FastEthernet0/0
O 2001::3/128 [110/2]
via FE80::C801:9FF:FE90:6, FastEthernet0/0
via FE80::C803:DFF:FE7C:8, FastEthernet0/1
O 2001::4/128 [110/1]
via FE80::C803:DFF:FE7C:8, FastEthernet0/1
O 2001::5/128 [110/1]
via FE80::C805:9FF:FEB4:8, FastEthernet1/0
R1#<input>show ipv protocols</input>
IPv6 Routing Protocol is "ospf 1"
Interfaces (Area 0):
FastEthernet0/1
FastEthernet0/0
Loopback0
Interfaces (Area 1):
FastEthernet1/0
Redistribution:
None
R1#
Stub Router
Event though we havn't got any external routes in our network we get a default gateway, on the stub network
R5#<input>show ipv protocols</input>
IPv6 Routing Protocol is "ospf 1"
Interfaces (Area 1):
FastEthernet0/0
Loopback0
Redistribution:
None
R5#<input>show ipv route ospf</input>
IPv6 Routing Table - 8 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
U - Per-user Static route
I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
<notice>OI ::/0 [110/2]
via FE80::C800:9FF:FE90:1C, FastEthernet0/0</notice>
OI 2001::1/128 [110/1]
via FE80::C800:9FF:FE90:1C, FastEthernet0/0
OI 2001::2/128 [110/2]
via FE80::C800:9FF:FE90:1C, FastEthernet0/0
OI 2001::3/128 [110/3]
via FE80::C800:9FF:FE90:1C, FastEthernet0/0
OI 2001::4/128 [110/2]
via FE80::C800:9FF:FE90:1C, FastEthernet0/0
R5#<input>show run | sec router ospf</input>
ipv6 router ospf 1
router-id 0.0.0.5
<notice>area 1 stub</notice>
R5#